\   /\          __    _____        _____     _____ _ _____
)  ( ')        |  |  |  _  |   ___|  _  |___|  |  |_|_   _|___
(  /  )        |  |__|     |  |  _|     |_ -|     | | | | | .'| 
 \(__)|        |_____|__|__|  |___|__|__|___|__|__|_| |_| |__,|

 
 Si disponemos de mas de 2 routers y necesitamos que conecten varias redes
podemos usar protocolos de enrutamiento o si no queremos usar dichos protocolos
podemos configurar las rutas estaticamente.
En el siguiente ejemplo configuraremos los routers para que el router R1
pueda comunicarse con el router R3.

Smiley face

Empezaremos por configurar las ips. En nuestro ejemplo usaremos la
siguiente configuracion:

R1:fa0/0 10.10.10.1 255.255.255.0
R2:fa0/0 10.10.10.2 255.255.255.0 e2/0 20.20.20.1 255.255.255.0
R3:e2/0 20.20.20.2 255.255.255.0

Para configurar el R1:

configure terminal
interface fa0/0
ip address 10.10.10.1 255.255.255.0
no shutdown
Se puede apreciar en la imagen como la interfaz Fa0/0 se pone up. Smiley face Por otro lado ejecutando el comando show ip int brief.
show ip int brief
Podemos comprobar que la interfaz tiene la ip que le hemos asignado y que tanto el status como el protocol esta up. Smiley face Para configurar el R2:
configure terminal
interface fa0/0
ip address 10.10.10.2 255.255.255.0
no shutdown
exit
interface e2/0
ip address 20.20.20.1 255.255.255.0
no shut
Smiley face Para configurar el R3:
configure terminal
interface e2/0
ip address 20.20.20.2 255.255.255.0
no shutdown
Smiley face Ejecutando el comando show ip route podremos comprobar las rutas que actualmente tiene el router.
show ip route
En el caso de R1 vemos que la red 10.10.10.0 esta directamente conectada. Smiley face En el caso de R2 vemos que las redes 10.10.10.0 y 20.20.20.0 estan directamente conectadas. Smiley face Por ultimo en R3 vemos que la red 20.20.20.0 esta directamente conectada. Smiley face Configuradas las ips, podemos comprobar que R1 puede hacer ping a R2 pero no a R3, R2 puede hacer ping a R1 y a R3, y R3 puede hacer ping a R2 pero no a R1. Para que puedan comunicarse R1 con R3 y viceversa configuraremos la ruta estatica. Para ello agregaremos la ruta estatica tanto en R1 como R3. Para que puedan comunicarse es IMPORTANTE declarar las rutas en ambos routers. La sintaxis para definir una ruta estatica es la siguiente:
ip route red_destino mascara_red ip_router_o_interfaz_conectado_a_esa_red
Empezamos configurando la ruta estatica en R1:
configure terminal
ip route 20.20.20.0 255.255.255.0 10.10.10.2
o
configure terminal
ip route 20.20.20.0 255.255.255.0 fa0/0
Para agregar ruta estatica R3:
configure terminal
ip route 10.10.10.0 255.255.255.0 20.20.20.1
o
configure terminal
ip route 10.10.10.0 255.255.255.0 e2/0
Una vez configuradas las rutas estaticas en ambos routers, podemos comprobar las rutas que tiene actualmente el router. En R1 podemos ver que la red 10.10.10.0 esta directamente conectada y que la red 20.20.20.0 la encuentra a traves del router 10.10.10.2 (R2). Smiley face En R3 podemos ver que la red 20.20.20.0 esta directamente conectada y que la red 10.10.10.0 la encuentra a traves del router 20.20.20.1 (R2). Smiley face Y ya para terminar, solo nos falta hacer ping desde R1 a R3 y viceversa. Smiley face Smiley face Ya tendriamos comunicacion entre todos los routers!