\   /\          __    _____        _____     _____ _ _____
)  ( ')        |  |  |  _  |   ___|  _  |___|  |  |_|_   _|___
(  /  )        |  |__|     |  |  _|     |_ -|     | | | | | .'| 
 \(__)|        |_____|__|__|  |___|__|__|___|__|__|_| |_| |__,|

 
 RIP es un protocolo de enrutamiento dinamico que permite que los routers compartan las redes que conocen.
Es un protocolo vector distancia, y para determinar la metrica de la ruta cuenta los saltos que
hay desde un router hacia otro, su distancia administrativa es de 120.
Si RIP contiene una ruta con metrica 16 la tomara como inalcanzable.
Hay 2 versiones del protocolo RIP, y los routers deben utilizar la misma version.
A diferencia de RIPv1, RIPv2 soporta sub-redes, VLSM, CIDR, resumen o sumarización de rutas, posee mecanismos de 
autenticación mediante texto plano o codificación con encriptamiento MD5, y realiza actualizaciones 
desencadenadas por eventos.

Al configurar RIP no hay necesidad de configurar rutas estaticas sino que los routers comunican
a que redes estan conectadas, y de esta manera "aprenden" como llegar a rutas que no estan directamente
conectadas a ellos.

En el siguiente ejemplo configuraremos los routers para que el router R1
pueda comunicarse con el router R3.

Smiley face

Empezaremos por configurar las ips. En nuestro ejemplo usaremos la
siguiente configuracion:

R1:fa0/0 10.10.10.1 255.255.255.0
R2:fa0/0 10.10.10.2 255.255.255.0 e2/0 20.20.20.1 255.255.255.0
R3:e2/0 20.20.20.2 255.255.255.0

Para configurar el R1:
configure terminal
interface fa0/0
ip address 10.10.10.1 255.255.255.0
no shutdown
Smiley face Para configurar el R2:
configure terminal
interface fa0/0
ip address 10.10.10.2 255.255.255.0
no shutdown
exit
interface e2/0
ip address 20.20.20.1 255.255.255.0
no shut
Smiley face Para configurar el R3:
configure terminal
interface e2/0
ip address 20.20.20.2 255.255.255.0
no shutdown
Smiley face Ahora es momento de configurar RIP. Para configurar rip solo debemos especificar que redes tiene el router conectadas directamente. Para configurar el R1:
conf t
router rip
network 10.10.10.0
Smiley face Para configurar el R2:
conf t
router rip
network 10.10.10.0
network 20.20.20.0
Smiley face Para configurar el R3:
conf t
router rip
network 20.20.20.0
Smiley face Para comprobar que se han actaulizado las rutas podemos comprobarlo usando el comando:
show ip route
En el R1 podemos ver que conoce la red 20.20.20.0 a traves del 10.10.10.2 y que tiene al principio de la linea la R de RIP. Smiley face En el R3 podemos ver que conoce la red 10.10.10.0 a traves del 20.20.20.1 y que tambien tiene al principio de la linea la R de RIP. Smiley face Ahora que hemos terminado la configuracion, vamos a probar que hay conectividad haciendo ping de R1 a R3: Smiley face Y haciendo ping de R3 a R1: Smiley face Por ultimo, se puede ver la base de datos de las rutas usando el comando:
show ip rip database
Por ejemplo, en el R1 la base de datos seria: Smiley face Y esto es todo :) Ya tendriamos RIP configurado!