\   /\          __    _____        _____     _____ _ _____
)  ( ')        |  |  |  _  |   ___|  _  |___|  |  |_|_   _|___
(  /  )        |  |__|     |  |  _|     |_ -|     | | | | | .'| 
 \(__)|        |_____|__|__|  |___|__|__|___|__|__|_| |_| |__,|

 
 En sitios que existe un firewall que no permite el trafico TCP hasta "registrarnos" pero ICMP esta permitido, ptunnel es nuestro amigo.
Lo podemos instalar con:

	
sudo apt-get install ptunnel
Usaremos ptunnel en nuestro laboratorio para acceder a Internet. En nuestro laboratorio usaremos GNS3 con 1 router (Etherswitch + 3 Maquinas Virtuales). * 1 VM que sera nuestro "PC del curro". * 1 VM que sera "PC de casa" * 1 VM que sera "Internet". En este caso usamos 3 maquinas virtuales para este POC, pero en la vida real si teneis ping a cualquier sitio de internet, debereis tener ping al ordenador de tu casa. Recuerda que en la vida real, debes usar la ip publica del pc de tu casa. Nuestro laboratorio deberia quedar asi: Smiley face En el PC de Oficina configurar:
ifconfig eth0 up
ifconfig eth0 192.168.1.10 netmask 255.255.255.0
route add default gw 192.168.1.1
En el PC de casa configurar:
ifconfig eth0 up
ifconfig eth0 88.10.20.20 netmask 255.255.255.0
route add default gw 88.10.20.1
Para simular Internet:
ifconfig eth0 up
ifconfig eth0 : 99.22.33.30 netmask 255.255.255.0
route add default gw : 99.22.33.1
Para configurar el router:
configure terminal
interface fa0/0
ip address 192.168.1.1 255.255.255.0
no shutdown
exit
interface fa1/0
ip address 88.10.20.1 255.255.255.0
no shutdown
exit
interface fa2/0
ip address 99.22.33.1 255.255.255.0
no shutdown
exit
Ahora, no hay restricciones asi que podemos probar a visitar http://99.22.33.30 usando el ordenador de nuestra oficina. Smiley face Bien, ahora vamos a agregar restricciones y solo permitir ICMP para probar el tunel. Vamos al router de nuevo y ponemos:
configure terminal
access-list 101 permit icmp any any
access-list 101 deny ip any any
Necesitamos aplicar estas access-list en la interfaz IN de la oficina asi que:
configure terminal
interface fa0/0
ip access-group 101 in
Si probamos de nuevo a visitar http://99.22.33.30 usando nuestro ordenador de oficina aparece: Smiley face Momento de hacer el tunel! En el ordenador de casa:
ptunnel
Se puede agregar un password usando ptunnel -X PASSWORD En el ordenador de la oficina pon:
ptunnel -p 88.10.20.20 -lp 8000 -da 99.22.33.30 -dp 80 -c eth0
Si pones password usando ptunnel -X PASSWORD, el cliente deberia ejecutar: ptunnel -p 88.10.20.20 -lp 8000 -da 99.22.33.30 -dp 80 -c eth0 -X PASSWORD Con el tunel hecho, si visitamos http://localhost:8000 en nuestro ordenador de oficina visitaremos realmente 99.22.33.30 Ordernador de oficina navegando: Smiley face Ordenador de casa: Smiley face Recuerda que puedes crear tuneles tambien para servidor ssh, ftp etc... solo se necesita adaptar el puerto de destino.